Migrate from GitHub to SourceForge with this tool. Check out all of SourceForge's recent improvements.
Close

#1898 Console Plugin shows InterruptedIOException after some commands

None
open
nobody
None
5
2018-01-23
2018-01-19
Ronald
No

When I enter a command in the shell of the console plugin, the command is always executed correctly, but in the end, strange error messages are displayed in red; an example can be seen at the attached screenshot. The red message is at least "Process .... exited with code 0", which is technically correct, but should not be marked as error. In addition, I sometimes see a Java exception displayed.

It's not that the Console plugin would not work at all; I can use it, but the error messages are somewhat disturbing.

1 Attachments

Discussion

  • Ronald

    Ronald - 2018-01-19

    Additional information about the Platform:

    Windows 7 (64bit)
    Java 1.8.0
    jEdit 5.4.0

     
  • Alan Ezust

    Alan Ezust - 2018-01-19
    • status: open --> closed-works-for-me
    • Group: -->
     
  • Alan Ezust

    Alan Ezust - 2018-01-19

    plugin options - console - system shell - uncheck the option 'show exit status'

     
  • Ronald

    Ronald - 2018-01-19

    I'm not refering to showing the exit status. This is perfectly fine. I want to see the exit status.

    Please pay attention to what I reported on. I reported that an exit code 0 is treated as error, and that I can see a Java exception.

    As for the exit status, if the desired behaviour is to always treat an exit status as error, I understand that this is not an issue. The Java exception still might be.

    I also don't quite understand, that a ticket is closed, just because one person exists who doesn't happen to see this behaviour. I am a software developer myself. A bug does not mean that one person in this world does not see a buggy behaviour; it means that there is some person who does see a buggy behaviour.

    I am aware that there are bugs which show up under certain circumstances only, so some people can see them and some people don't. This is not unusual. I also understand that you can not attempt to fix a bug, if you are not able to reproduce it. I am of course willing to provide support as much as I can. If you need additional logging information and tell me how I can turn on logs, I will happily provide this information. Just closing this ticket because the assigned person can not reproduce it, is, IMHO, a bit strange.

     
  • Alan Ezust

    Alan Ezust - 2018-01-19
    • summary: Console Plugin shows strange error messages after each comman --> Console Plugin shows InterrupedIOException after each command
    • status: closed-works-for-me --> open
     
  • Alan Ezust

    Alan Ezust - 2018-01-19
    • summary: Console Plugin shows InterrupedIOException after each command --> Console Plugin shows InterruptedIOException after each command
     
  • Alan Ezust

    Alan Ezust - 2018-01-19

    ok I changed the subject. I can not reproduce this issue though.

     
  • Ronald

    Ronald - 2018-01-22

    I suggest that you change the title to ".... after some commands". While the red error status is shown always, the exception shows up only sometimes. Is there something I can do, such providing logfiles?

     
    • Alan Ezust

      Alan Ezust - 2018-01-22

      ok I changed the subject again. Any info or relevant logs about how to reproduce it will be appreciated.

       
  • Alan Ezust

    Alan Ezust - 2018-01-22
    • summary: Console Plugin shows InterruptedIOException after each command --> Console Plugin shows InterruptedIOException after some commands
     
  • Ronald

    Ronald - 2018-01-23

    I wanted to check if I can see something in the jEdit Activity log, but starting from today (and without having changed anything in the configuration of jEdit), the Java Exception does not occur anymore, no matter how hard I tried! The only oddities are, that the message Process exit exited with code 0 is shown in the colour for error messages instead of information messages, and that typing exit does not close the console window. I don't know whether these are really bugs; maybe this is the intended behaviour.

    I will try a couple of days more, and if the error occurs again, I will check the activity log.

     

Log in to post a comment.